Cannot start WhatPulse using Ubuntu 19.10

Hello, just installed a fresh Ubuntu 19.10 with the Qt dependencies and libpcap-dev

Downloaded the x64 Ubuntu release and tried starting ./whatpulse after running the script.

Getting these logs :

30-10-2019 21:50:55.813 INFO “Starting WhatPulse 2.8.4-1633…”
QObject::startTimer: Timers cannot have negative intervals
30-10-2019 21:50:55.892 DEBUG Database file: “/home/adri/.local/share/WhatPulse/whatpulse.db”
Application crashed with signal 11!
Aborted (core dumped)

Tried with/without Wayland, tried the debian x64 dist, tried running as root (crashed because no system tray). Also tried some internet solution by modifying variables when running, did not work.

Seeing other threads, it might be time to actually make a new open source whatpulse on our own, since theres no apparent support anymore…

The devs will never opensource WhatPulse because they are afraid that the ranks will get cheated on (which I understand tbh). But I don’t need ranks so I really don’t care about that part so ya…
But the team is undermanned at the moment and I hope they will resolve it soon. Until then I’m thinking about cancelling my premium cause I can’t even use WhatPulse :(.

Canceled it a long time ago …

Edit: Yeah they just removed linux distributions from Downloads, why answer to and fix problems when you can just bury them. I guess we linux users aren’t worth it anymore ?

The download for the Linux client has been removed for now. Due to several changes in several distros, the client is unable to run on ~80% of the systems of people who try it. A few volunteers have stepped up to see about getting it running universally on every/most distros, but that will take a while. In the mean time, there’s not much we can do.

Are there any news regarding this topic?

No, they are still working on getting it to work.

Either way, happy to hear the linux client is getting some much needed attention. Thank you for the update!

Thanks WhatPulse team for releasing a version for Linux :D.