Cannot Login v2.1.1 (Windows 7)

I have mad my account on the website. When I try to login from the client, nothing happens for about 10 seconds, and then I recieve the error message
An error has occurred while communication with the website: Socket operation timed out. Please try again!
All the tabs remain greyed out, and I can only click “Settings” and “Setup Account”.
My antivirus, Norton 360, runs in the background, but it notifies me every time something is stopped, like if it conflicted with this program. So I heavily doubt that is the problem.
I have tried multiple times to no avail, tried reinstalling, running as admin, all of the usual fixes.

Please Help!

Build: Win7, x86, 64bit, v2.1.1

UPDATE: This error also occurs if I try to “Check for Updates”

Do you need to use a proxy to get out of your network? All communication go through https (443) to the same pool of IPs where the website is on, so if you can visit it, there -is- a way for you to connect. Question is what is blocking it on your computer or firewall.