"Cannot connect to keyboard"

So, I was fixing my cousin’s computer (ended up just formatting it and putting Windows 98 back on it) and now I am all done. However, I tried putting Whatpulse on his computer (he’ll join my team; kinda-sorta payment) but I get that error.

Odd. Is it a USB keyboard or PS/2?


Sorry, I am not familiar with these terms.

It is not a USB, it is a standard keyboard the modern small port.

Now, I know this is not a keyboard problem as I am using my PC’s keyboard.

The modern port, aka the circular one, is called PS/2. It’s not modern, it’s actually the oldest type still in use today. Anyway, not important. It seems strange that it wouldn’t work however.

It could just be the computer is rejecting WhatPulse, or the keyboard is messed up itself in its hardware configuration within Windows 98. There’s no real way to tell.

That’s my two cents.


Hm, I seem to remember my first computer having a similar looking port, only much larger. Maybe it was a combination of my small hands and faulty memory.

Anyway, I’m sure it isn’t a problem with the keyboard, as several have not worked. Anyone else have any ideas?

The old version of WhatPulse is no longer supported and nor can it be downloaded from this website…

I doubt it’ll be the keyboard and it has nothing to do with the port. If you haven’t tried already, completely uninstall WhatPulse (from the control panel, and after you’ve done that, delete the WhatPulse directory from Program Files). Then download WhatPulse from here again and install it. Might work.

If you use a USB keyboard on 98, does that give the same error?