Application freezing, and using 25%cpu

Whatpulse: 2.6.1 and previous 3 versions.
OS: Windows 7 NT x64
winpcap: Check
admin/admin mode: Check, Check.
Programs running: Firefox, skype, visual studio, unity3d, notepad, windows media player, steam, utorrent, teamviewer, gyazo, ccleaner, avg in limited mode.

In the last 3 versions of whatpulse client I had the client, after a certain amount of time freezes and starts using 25%cpu.

The window can be minimized and maximized, but after clicking in the screen once or twice it will crash.

Any notice on AVG or ccleaner? This is usually something that is blocking the client from doing it’s job on which it freezes. If there are no notices, try turning those programs to a verbose kind of logging and see if something comes up then. If that also gives no messages, try to either disable networking stats or uninstall WinPcap for a while to test, WinPcap also sometimes throws some stones to the client.

No notices from avg/ccleaner, neither did verbose logging turn up with anything. Tried disabling WinPcap, this help in such a way that it took a xxx duration longer before the freeze happend, and the application did no longer run at a full 25% cpu, but dangled between 17 and 25%

Strange…have you tried a complete reinstall of the client program? Just to make sure you don’t have any old files that are being used.

I think I’ve had this issue a few days ago. The client would stop counting anything, with the geek window freezing on the same stats. If I clicked the geek window it would turn white and say that it’s not responding.
It happened around 3 times a day I’d say, which was very annoying because I lost some stats. Updating/reinstalling and other things I’ve tried didn’t do anything, but I managed to fix it by deleting everything in the appdata/local/whatpulse folder along with a reinstall. My local stats and geek window layout were lost, but nothing could be done about that I guess.

Tried a clean re-install (wipe all old data) took quite a while before it happend again. Here the crash report windows gives me :

Een probleem heeft ervoor gezorgd dat dit programma niet meer met Windows communiceert.

Gebeurtenisnaam van probleem: AppHangB1
Naam van de toepassing: whatpulse.exe
Tijdstempel van toepassing: 558fdb45
Handtekening van vastlopen: bc9f
Type vastlopen: 0
Versie van besturingssysteem: 6.1.7601.
Landinstelling-id: 1043
Aanvullende handtekening 1: bc9f2da33b045327ddb30dfd57dc0e32
Aanvullende handtekening 2: 4fc2
Aanvullende handtekening 3: 4fc25cd60fa2f6f92a30a0a49a378adf
Aanvullende handtekening 4: bc9f
Aanvullende handtekening 5: bc9f2da33b045327ddb30dfd57dc0e32
Aanvullende handtekening 6: 4fc2
Aanvullende handtekening 7: 4fc25cd60fa2f6f92a30a0a49a378adf

Lees de onlineprivacyverklaring:

Als de onlineprivacyverklaring niet beschikbaar is, lees dan onze offlineprivacyverklaring:

i’m also having hangs (also on a dutch windows version)
i’m using a headless windows xp pro which is running a dedicated fileserver/mailserver software and is further not equipped with firewall software (my router takes care of that; and the pc only uses the ports for tls/ssl-email; unsecure mail not allowed except for smtp delivery from other servers)

i’ve been running whatpulse for years on this server without issues but lately it’s hanging… when it starts it immediately goes to 25 and 50% cpu usage (max allowed of the dual core cpu) and i can only open the interface but it won’t react…

i tried reinstalling it; even tried going back to older versions but that doesn’t seem to work either since those are hanging now too (and they worked perfect in the past). On my other computers i have no issues (win vista/7/10, xubuntu)

the xp machine is not running a systemwide antivirus like avg, gdata, norton or alike, it’s only running a daemon for the mailer

edit: i just removed winpcap to check if that would help… the app doesn’t hang anymore…; but off course now it’s only counting uptime and no more datatraffic… how can i resolve this problem?

Yeah, it’s an issue with WinPcap, my whatpulse started freezing again after my post, but much more rarely. I noticed it happened whenever my router screwed up and my internet stopped working for a while.
The last line before the freeze in the app.log is this:

16-07-2015 11:46:06.691 DEBUG void __thiscall PcapNetworkTrafficMonitor::refreshInterfaces(void) Unable to find network interfaces via normal APIs, trying pcap alternative.. 

Disabling network statistics fixes the issue, but I’d rather keep them.

Since installing Nmap I no longer have this issue on my laptop. It seems that Nmap came with a more recent version of winPcap.

Having virtual internet adapters, such as VMware, Hamachi seems to have been the culprit for my desktop. Removing them prevented freezing. I also confirmed that when tunnelling your connection over a virtual adapter the freeze does not seem to happen either.

Hope my solution can also help you

ps the error still persists in WP 2.7