Apology to Martijn Smit (smitmartijn)

My apologies to Mr. Martjin Smit,

I’m here writing to you because I’m sorry for the inconvenience I caused you in http://www.whatpulse.org/forums/showthread.php?tid=4752&pid=34112#pid34112.
I wasn’t subscribed to http://whatpulse.org/forums/showthread.php?tid=5132&page=2 and I had forgotten I had a reply in there so never knew the status of the thread. If I had downloaded your update from there, I’m sure my problems would have been solved right away just like you had said. However, I am a little taken aback by

“I’m not sure what timezone you’re in, but here on earth 20 days is not even 1 month, let alone ‘many months’.”

The last reply I made was in June, I think you read 06-09-2014 incorrectly as September 6 when it actually is June 9. As you can see from the post before above it, the date is written 05-20-2014, the first number corresponds to month. But, I understand that you’re a real person, none other than the founder of Whatpulse, responsible for the overall direction and development of the client and websites. And admittedly, I also deserved it.

Today, turning on my computer, I was notified to install a new update. Looking at the quick rundown at the patch notes, I finally got what I was waiting for. It has been about an hour and Whatpulse has not exceeded 3MB yet. And for that I commend you, whatever engineering you did. I believe it was trimming down the .db file in app data? Anyway, keep up the good work. I will continue to support your endeavors in the project by alerting you to any new problems I encounter.

Yours sincerely,


Hi Dullahan8,

It wasn’t an inconvenience, I just have a small trigger for people making d***ish posts without actually looking at the overall context (forums or help center). And yes, I mistook the date format as I thought I set it to my own one. Sorry about that one, it made the reaction a bit harsher then it should have been. But still, I think there’s a debate that can be had whether 3 months is many months. :wink:

Good to hear the update has also fixed it for you.