2.0 Client complaining of higher version of glibc on RHEL6 and CentOS 6

I have been a WhatPulse user for quite some time. I got the email saying version 2.0 was ready and available for download, so in my excitement I rushed over to grab it.

I was running version 1.2 (I believe that was the version) on my RHEL 6.3 workstation for a while, but when I tried to run the new client it complains of needing version 2.14 of GLIBC.

Here is the error:
./whatpulse: /lib64/libc.so.6: version `GLIBC_2.14’ not found (required by ./whatpulse)

And here is the output of rpm -qa glibc on my machine:
[root@dgs6hlfbt1 whatpulse]# rpm -qa glibc

So, it appears that the new version of the client was built with a newer version of glibc than most of the stable distributions are using (Debian, Redhat CentOS, Scientific Linux, etc).

Is it possible to fix this to run on the version of glibc that most of the stable distros are running?

Yes an no… As noted in several other topics; WhatPulse-developers don’t have a very high priority fixing the compatibility on Linux-distros.

Have you tried building & linking glibc-2.14. from unstable source into your kernel?

Well this is unfortunate. I really don’t like the idea of having to build glibc from unstable source just to have whatpulse. This is my work machine and I don’t want to run the risk of breaking it by jacking with glibc.

Why did they choose to build with such new packages of glibc that only a small subset of distros use it? Is there a definite toolset they need that’s not in 2.12?

Unsure why the 2.14 was chosen; from what I’ve understood in other topics that smitmartijn replied to, it was mainly tested on current Ubuntu distros like 12.04LTS that carry the required libs by default.

As you more than sensibly point out; a small market is being served and longtime distro’s are being left out the WhatPulse-cycle at the moment. I don’t like cutting-edge libs like the Ubuntu-cycle but at the moment we’re not in luck :slight_smile: