2.0.4 Freezing Problems

Hi,

Back in 2.0.3, there were freezing problems caused by WhatPulse. From what I’ve gathered, its because when WhatPulse writes to the database, it runs it on the main thread, freezing it, and prevents it from sending keyhooks back to Windows. This issue is still in 2.0.4, causing occasional freezes. I’m reverting back to 2.0.2 which does not have this issue

Yeah I’m getting lag too on keyboard and mouse every 5 minutes (save to database ?). Which is highly inconvenient

When did you download the 2.0.4 installer? There was a window of about 2 hours (300-ish downloads) where there was a wrong installer online. It contained a built that still did that, it was updated a little while after the main release.

I downloaded it about 5 hours after the email notification was sent out. The installer was 2.0.4 though.

Just redownloaded and reinstalled 2.0.4, but the problem still persisted. Downgrading to 2.0.2 fixed it.

Yep same here. Still using 2.0.2. It crashes occasionally so I created a scheduled task to run it once a day. It usually crashes when it should do a scheduled pulse

in 2.0.2 you have open the wp programwindow to prevent it crashing :wink:

What kind of keyboard do you have? What OS?
Do you have any software running related to input? XFire, Intellisense, music player app that responds to hotkeys maybe?

I’m a developer, so I’ve attached an external keyboard and mouse to my laptop computer. I’m also running VS 2012 and of course using Intellisense

I’m running…

OS: Windows 8 Pro 64bit
Mouse: Logitech MX518 Mouse
Keyboard: Logitech G15 Original (18 G- Keys + LCD Screen)

No to Xfire, No to Intellisense (Unless its installed with Windows), and I use Foobar2000. I didn’t have this problem until I upgraded from 2.0.2 to 2.0.4. I skipped .3 and went straight to .4 since I didn’t check my email in time.

Hope this helps dutchmega!

Edit:

Win Pcap doesn’t work on Windows 8 either. So I think that may be a part of the problem.

winpcap works on win8!

  1. update windows (compatability update is available)
  2. download from http://www.winpcap.org/install/default.htm

I have this issue too. After upgrading to 2.04 my entire comp completetly freezes up every so often (~5mins) unable to move mouse or anything. Windows 8 64bit

Downgrading to 2.02 fixed problem.

I’ve yet to have any 2.x versions of WP work on any of 3 systems. Win 8 x64, Win 7 x64, or Win 7 x86. It’ll usually run for about an hour then magically crash but not tell me. Have to swipe the mouse over the icon in the systray to get it go away (Windows related, yes).

I went from 20k-30k key presses a day to 26k total since updating to 2.x shortly after release.

I’ve even recently formated my 32-bit Win 7 box and tried it again 2.0.1 - 2.0.4 … Same thing.

WinPCap works on my Win8 Enterprise edition though. And the .2 and .3 are in the forums only. What’s ironic is while I’m writing this post, WhatPulse just crashed. I hope we can revert back to the 1.7 version since it’s getting a little annoying with the bugs. I know this isn’t really a commercial product and we are in no position to complain, but at least updates on the next fixes would be great

I just now found out it has been whatpulse that has been freezing my mouse and keyboard every few minutes. I spent 100$ on ram and a new mouse to no avail. :confused:

If only the next version works just like 2.0.2 which doesn’t have the freezing problem, but with improved stability of 2.0.4

Win Pcap with the WP install doesn’t work on Windows 8. It has issues. I ran the installation in Administrator mode, and it installed perfectly.

Though, this stuttering of the mouse, is absolutely, insane.

ETA on a fix?!

I got these freezing problem also after updating from 2.0.2 → 2.0.4.
Win8 64bit
Wincap installed

Laptop keyboard, simple mouse

I can confirm this issue. Whatpulse version installed: 2.0.4
Keeps freezing just for a lil second every 5 min or so.
Really annoying when playing Counterstrike :stuck_out_tongue: